Sena Re (senare) wrote in component_help,
Sena Re
senare
component_help

Compile Errors and moving edit features - SOLVED

Layer ID: 6955684

I almost have everything the way that I want it except for the link option and the edit features. So I suppose I have a problem and a question.

Problem: I have the CTE code in place, I'm also using the code for the metadata in a box as well as the code to place the mood icon to left of metadata. Everything is fine up to this point, however when I go to take the link option out I get compile errors one right after the other the first one is:
Compile error: line 901, column 8: Unexpected token found. Expecting: [TokenPunct] = (
Got: [TokenIdent] = info
S2::Node, S2/Node.pm, 144
S2::NodeArguments, S2/NodeArguments.pm, 25
S2::NodeTerm, S2/NodeTerm.pm, 450
S2::NodeIncExpr, S2/NodeIncExpr.pm, 41
S2::NodeTypeCastOp, S2/NodeTypeCastOp.pm, 29
S2::NodeInstanceOf, S2/NodeInstanceOf.pm, 29
S2::NodeUnaryExpr, S2/NodeUnaryExpr.pm, 40
S2::NodeProduct, S2/NodeProduct.pm, 28
S2::NodeSum, S2/NodeSum.pm, 31
S2::NodeRelExpr, S2/NodeRelExpr.pm, 29
S2::NodeEqExpr, S2/NodeEqExpr.pm, 29
S2::NodeLogAndExpr, S2/NodeLogAndExpr.pm, 29
S2::NodeLogOrExpr, S2/NodeLogOrExpr.pm, 29
S2::NodeRange, S2/NodeRange.pm, 29
S2::NodeCondExpr, S2/NodeCondExpr.pm, 29
S2::NodeAssignExpr, S2/NodeAssignExpr.pm, 29
S2::NodeExpr, S2/NodeExpr.pm, 29
S2::NodeExprStmt, S2/NodeExprStmt.pm, 28
S2::NodeStmt, S2/NodeStmt.pm, 59
S2::NodeStmtBlock, S2/NodeStmtBlock.pm, 42
S2::NodeFunction, S2/NodeFunction.pm, 104
S2::Layer, S2/Layer.pm, 58
S2::Compiler, S2/Compiler.pm, 27


Context

897: # build userpic and posterinfo
898: # don't edit these
899: var bool show_poster = ($p.view == "friends" or $p.journal.journal_type == "C"); # figure out if we're going to show
900:
901: poster info
902: var bool show_userpic = false; # figure out if we're going to show
903:
904: userpic
905: var bool scroll_entry = false; # figure out if we're going to make a


Once I have that resolved others seem to pop out of the woodwork but only happens when I try to remove the link.

The question is on the edit buttons. I know that CTE automatically places the edit buttons at the bottom of a post. What I would like to do is to return them back to the right side of the user icon. I've searched through memories and tags and thought I had found the solution but recieved a 404 error instead.
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic
  • 4 comments